Remember Me
Hide Me

Main Menu


Total posts 339150
Total topics 40045
Total members 7519
Our newest member dabassassassin

Question 2017 20hp Merc

Anything and everything related to boating, motors, and electronic equipment. Find out the answers to your questions here.
  • Supported By...

Question 2017 20hp Merc

Postby Ammokingjr » Thu Aug 03, 2017 5:47 pm

Good day, I'm having some troubles with my 20HP Merc. Recently I have hit a couple rocks and logs (never going too fast) maybe 10km tops and now my motor is leaking some fuel. Still runs fine tho. I am also no longer able to raise the motor when in the raised position. any help would be greatly appreciated.... Damn Ottawa river
User avatar
Posts: 3
Joined: Fri May 26, 2017 1:12 pm

Re: Question 2017 20hp Merc

Postby Roblin » Sat Aug 05, 2017 4:16 am

The fuel leak is probably a loose connection. You'll have to remove the cowl and look for it. Pump the bulb and it may show. If not run the motor in water and look for the leak. Wipe everything dry with paper towels and look for the wet. Hopefully something is loose. If the leak started in conjunction with hitting something, you may have a bigger problem.
As for the motor not raising, sounds like you warped something in the mount. Hopefully it's light weight and you can bend it back. You'll have to spend some time and look for what's bent or binding.
If you can't find it you'll have to take it to the shop.
Good luck.
User avatar
Bronze Participant
Bronze Participant
Posts: 109
Joined: Sun May 12, 2013 11:05 am

Return to Boats, Motors, & Electronics

Who is online

Users browsing this forum: No registered users and 6 guests

  • Supported By...